Clutch issue - Page 9 - Kawasaki Ninja 1000 Forum
 13Likes
Reply
 
LinkBack Thread Tools
post #81 of 81 Old 05-14-2019, 03:11 PM
Senior Member
 
Join Date: Dec 2013
Posts: 8,572
Quote:
Originally Posted by Histaminium View Post
Thanks for the info rcannon. My question really was after the fact of the mod?

Has anyone experienced slipping feeling of the clutch after drilling the hub? But did not feel it before drilling it?

Also, a differenceni in feeling when finding neutral?
It should be better. Plates with more oil on them will be less likley to slip...not more. It takes very few "slips" to damage plates. If they are damaged' they need to be replaced. They are not fixable for the most part.
rcannon409 is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Ninja 1000 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome